It is currently Thu Jul 16, 2020 4:20 pm

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
 StartMap has teleporters disabled in my dedicated server 
Author Message

Joined: Sat Jun 06, 2020 5:45 am
Posts: 1
Post StartMap has teleporters disabled in my dedicated server
Hi everyone,

Since I tried to host a listen server to play with another player with no luck, now I'm hosting a dedicated server and we are able to join to the same game.

Thing is, when I host the dedicated server and join it, I can't login to the WorldServer (pressing O, using the bind that comes with the .bat, which already has my username and password from here) so we are stuck in the pregame.

I tried changing the map to StartMap from the dedicated console and the teleporters are disabled. Also tried to login to the WorldServer from the dedicated console and the command has no effect.

Am I missing something? This is the .bat to host the server:
start q2ded.exe +set wsrv_url http://www.coopordie.com/quake2/rpc +set dedicated 1 +set game coopordie +map pregame +set port 27910 +wsrv_login froztaine (my password)

Thanks!

Edit: I am able to login to the WorldServer if I run the mod from a listen server.

The dedicated server and the game's client are both run from the same computer.


Tue Jun 09, 2020 5:56 am
Profile
Champion in solo and duo and trio and quartet

Joined: Tue Jun 23, 2009 3:30 pm
Posts: 613
Post Re: StartMap has teleporters disabled in my dedicated server
Even if you were able to run a dedicated server, you'd have 1 extra player in the server which isn't exactly helpful... they would sit down there and die very easily.

I don't think Coopordie allows hosting dedicated servers. You seem to be the first one to ask about it.

Either way, it's very odd that your friend may join you on a dedicated server but not on a listen server, considering you're hosting them on the same machine. Have you tried running a vanilla Q2 server and connecting to each other? It should be no different, but you changed the map manually to Startmap without logging into the worldserver (if you type "worldserver" in the console you should see "0" or "false") you're nearly playing vanilla Q2.

I might be repeating myself (I remember a couple of people asking about connectivity issues these days...), but have you tried using Hamachi or a similar VPN tool (Gameranger, Tunngle, ... They all do the same) yet?

_________________
Quaking like it's the '98s.

Feel free to add me on Steam.


Tue Jun 09, 2020 10:39 pm
Profile YIM
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © phpBB Group.
Initial forum style by Vjacheslav Trushkin.